Scheduled maintenance tonight
Resolved
Jul 22, 2026 at 4:00am UTC
Maintenance ended
Affected services
Created
Jul 22, 2026 at 4:00am UTC
We'll be performing routine platform maintenance tonight, July 21. During this window, you won't be able to log in or operate on Meefi.
Maintenance window
- Date: July 21
- Time: 10:00 PM – 11:00 PM (Mexico City time)
- Availability: Full platform unavailable during the window
You don't need to do anything on your end — access will resume automatically once maintenance is complete. If you had a transfer scheduled during this window, it will process as soon as maintenance ends.
If you're still unable to access your account after 11:00 PM, please reach out to us.
Affected services